Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 24, 2025 - 08:00 UTC
Scheduled
Scheduled release planned for Wednesday, December 24th at 12:00 AM PST. During this release window, some users may experience temporary issues logging into the platform.
If you encounter any issues: - Please log out of the platform - Clear your browser cache - Log back in and try again
If the issue continues, contact our support team for assistance.
Posted Dec 24, 2025 - 07:34 UTC
This scheduled maintenance affected: GoKart Web Portal.